jQuery UI Widgets Forums Grid z-index issue with jqxGrid cell in jquery dialog

Tagged: ,

This topic contains 1 reply, has 2 voices, and was last updated by  Peter Stoev 9 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author

  • harsh
    Participant

    I am opening jqxGrid (with editing mode) in jquery dialog.
    Problem: it’s not allowing to edit a cell.

    After investigating I found that ‘div[role=”gridcell”]’ has the inline z-index which is lower than ‘input [editing]’s.
    If I increase the z-index of ‘div[role=”gridcell”] then it’s working fine. But Here I need to use ‘!important’ which I don’t want.

    Is there any option to set explicit z-index rather than allowing it at runtime (inline)? Also please share other solution if there is any.

    Thanks in advance!
    Harshal

    • This topic was modified 9 years, 8 months ago by  harsh.

    Peter Stoev
    Keymaster

    Hi Harshal,

    The editor is inside the cell so this is not related to z-index because the editor is a child of the cell. I don’t suggest you to modify any z-index set by jqxGrid. Your problem is probably related to the Dialog’s z-index and I suggest you to use higher z-index for your dialog or simply use jqxWindow instead.

    Best Regards,
    Peter Stoev

    jQWidgets Team
    http://www.jqwidgets.com

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.