jQuery UI Widgets Forums Grid Grid focus

This topic contains 18 replies, has 4 voices, and was last updated by  Peter Stoev 8 years, 9 months ago.

Viewing 4 posts - 16 through 19 (of 19 total)
  • Author
    Grid focus Posts
  • Grid focus #8557

    Peter Stoev
    Keymaster

    Hi Germán,

    In IE, the mouse pointer should be inside the Grid, if you want to use keyboard navigation. That is the default behavior.

    Best Regards,
    Peter Stoev

    jQWidgets Team
    http://www.jqwidgets.com

    Grid focus #76383

    rskumar
    Participant

    Peter,
    We are new to jqWidgets just a few months old. We have built a web based application using ASP.net. Solution makes extensive use of jdxGrid and jqxTreegrid. We are facing a serious problem in one scenario.
    We have a master tree grid with several rows in it. Selecting one row and clicking on an icon in the toolbar opens a data set in a popup window that has couple of search fields and 2 tabs , each of which is loaded with grids in a split view (jqxTreegrid in left side and corresponding detail data as jqxGrid on the right side). We select one or more rows from this popup window and use a right click enabled function to add the selected rows to the master grid in the parent window. We can repeat this process as many times as we want and it works fine. However, if we save the parent sheet by clicking save and reload the page for further editing,we are experiencing problems. The popup window shows up for sure when the icon is clicked, data can be seen in all the grids in both the tabs with split view. If we now try to select the row(s) from the grid inside one of the split view and right click+Add , the data does not get copied to the parent grid. Any idea on what we could be doing wrong ? Are we not using the widget properly ? Why should the system behave differently from the 1st time and 2nd time ? Your comments would be immensely helpful.
    As I am posting this, my team is looking for clues from your example above to check if it offers any solution.
    We are using jqWidgets ver 3.4.0 and we are on ASP.net ver 4.0/MS SQL Server DB/ Windows 7.
    Thanks in advance
    Kumar

    Grid focus #76403

    rskumar
    Participant

    Any response ? Or is this thread closed ?

    Grid focus #76404

    Peter Stoev
    Keymaster

    Hi rskumar,

    Your question seems to be specific to your app, not to jqxGrid. In addition, you’re using version which is old so the issue which you experience could already been resolved in newer version. At last, your question is not related to this Forum topic.

    Best Regards,
    Peter Stoev

    jQWidgets Team
    http://www.jqwidgets.com

Viewing 4 posts - 16 through 19 (of 19 total)

You must be logged in to reply to this topic.