jQuery UI Widgets Forums Grid Loading mask not showing in FireFox

This topic contains 2 replies, has 3 voices, and was last updated by  mkrajew 3 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • Loading mask not showing in FireFox #102124

    Admir Hodžić
    Participant

    My jqxGrid is attached remotely on json results.
    It is also has custom localization implemnted.
    Grid working very nice on(chrome, firefox, edge).
    Only problem whit my grid is that in FirFox there is no Loading… window during updatebound data.
    Browsers Edge i Chrome showing whitout problems loading mask, but that is not case whit fireFox

    When I open Firefox developer tools I get warnings like

    unreachable code after return statement[Learn More] jqxlistbox.js:7:15020
    unreachable code after return statement[Learn More] jqxlistbox.js:7:15020
    unreachable code after return statement[Learn More] jqxdata.export.js:7:66726
    Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help http://xhr.spec.whatwg.org/ jquery.js:9061:4
    unreachable code after return statement[Learn More] jqxlistbox.js:7:15020 

    Other grid functions in Firefox working well etc (soring, grouping, localtization and others.)

    Is there known issue whit loading mask in FireFox ?

    Here is screan recoding for additional explanaton

    https://photos.app.goo.gl/keufZVfHr3nyZm8W7

    Recoding

    Loading mask not showing in FireFox #102138

    Martin
    Participant

    Hello Admir Hodžić,

    I have tested this Example in Firefox and loading mask is showing normally.
    You can try setting its z-index css property. You can see this Example.

    Best Regards,
    Martin

    jQWidgets Team
    http://www.jqwidgets.com/

    Loading mask not showing in FireFox #103413

    mkrajew
    Participant

    For what it’s worth, I had this problem as well and I needed to set the z-index. The only browser that it wasn’t working on was Firefox and when I set the z-index (I also had to add !important) it worked fine.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.